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A

ClogAmp is a music player particularly tailored to the needs of clogging instructors. It is
widely used throughout Germany and is well known for its easy installation, ease-of-use
and speed. To download the newest version of CLOGAMP, please go to either
clogamp.com or http://sourceforge.net/search/?type of search=soft&words=clogamp

First of all, let’s give MARTIN ROHRBACH a standing ovation for his development
of this wonderful software and for his generous sharing with all Cloggers. Martin
is from Germany and quite a gifted dancer. ClogAmp is a huge gift to our
community and we are all very, very grateful for it. Thank you Martin!

Because there is little information currently available on how to operate, use and
customize ClogAmp, | have written these notes in the hope that you find them helpful.
These are my personal thoughts and suggestions and in no way are meant to function
as official documentation for ClogAmp.

FILELIST

The FILELIST is the large window that appears when the program boots up. (Refer to
the last page for a screen shot of ClogAmp.) The first time you open ClogAmp, this
page will be blank and No directory selected will be displayed above the Title bar.

The Filelist is comprised of folders you select, usually from within My
Music. You can select the file which houses the songs you want to
import by clicking on the yellow folder in the lower left hand corner of
the screen. The “Choose a directory” window will open.

Click on the “+” sign beside C:. Do NOT put a check in the C: "box". Doing so will
import your entire "C" drive into ClogAmp! Next locate your My Music folder, which is
usually found under “My Documents” and sometimes by individual “User”. Check the
box beside My Music. At the bottom of the window check Include Subdirectories. This
will import your entire music library into the Filelist.


http://www.clogamp.com/
http://sourceforge.net/search/?type_of_search=soft&words=clogamp
http://sourceforge.net/search/?type_of_search=soft&words=clogamp

You can manage the folders you want to import into the Filelist by clicking on the “+”
sign beside My Music, unchecking the My Music box and checking ONLY the My
Music subfolders you want to import. Leaving the “Include Subdirectories” box checked
will enable you to import all the music within those folders. If you want, save those
particular folders with a name to make them easier to load again (see Creating a
Profile).

Important: Your music files MUST be in either mp3 or wav file format to be accepted
by ClogAmp. However, since file settings (cue points, tempo, etc) only save in the
mp3 file format, you may want to convert all your music files to the mp3 format. If they
are in wma format, they must first be converted. | would suggest converting them to
mp3 format and this is the WMA converter that | use:

http://www.bestshareware.net/download/wmaconverter-platinum.htm

To select the font size you deswe in the FILELIST window, click on the UP and DOWN
directional arrows in the o

lower right hand portion of
the screen. The UP arrow
will increase the font size;
the DOWN arrow will
decrease font size.

» Right:Click:

==fon Column:
» [Headings f
Show/Hide
Dialog Box>-

Filelist
Font Size

Increase — -
Decrease —°

To configure column
headings to your liking,
right click on the horizontal
bar at the top of the
FILELIST, where the ‘
column headings are o Mg =
listed. There you will be

able to either “Hide” or “Show” the various columns.

To SELECT A SONG TO PLAY, do any one of the following:
1. Select the song with a click of the mouse.

2. Use the up and down directional keys to highlight a song OR hitting Page Up or
Page Down for even faster scrolling.

3. Type in the name of the song you want by holding the Shift Key down to go
directly to the song that you are typing. This usually takes only three keystrokes
to bring up the song, but you must type them fairly quickly. If you don't hold down
the Shift key, you will likely encounter difficulty since so many of the keys are
configured to certain program functions that it is likely that you will engage those
processes accidentally. Please note that the column heading named “Title” must
be the far left column in your Filelist and listed first in your dialog box in order to


http://www.bestshareware.net/download/wmaconverter-platinum.htm

use this search feature. Right click on the column headings to select the type and
order of column headings.

4. Hit CAPS LOCK button on the laptop, then type in name of song (somewhat
easier than holding down shift key). However, you must remember to disengage
CAPS LOCK for program to work properly again.

To LOAD A SONG IN THE PLAYER, do any of the following:
1. Hit the Enter Button.
2. Double click on the highlighted song.

3. Hit the space bar.

To PLAY a song: 3 | [
En 5 m [sara Evans - Coalmine (03:30)
1. Hit the keystroke “p”. o T2 | o wm [ 11 Tt > A C
2. Use your mouse to click on the green triangle |5 S %

on the player.

You can either choose to have the Player show how much time has elapsed since the
song started playing OR show how much time is remaining. Click on the time display to
toggle between the time displays.

You can also designate a key to toggle the time display by going to Extra=>Configure
Keys->Toggle Time/Remaining. Designate the key you want to assign to that function.
For more on key configurations, see later section titled, “Configuring The Keyboard.”

NOTE: Attempting to play a song before the filelist completely loads could cause
ClogAmp to crash. Also, closing your laptop while ClogAmp is open could cause
ClogAmp to crash.



CREATING A PROFILE

There may be times that you want to only load certain songs in your Filelist. ClogAmp
enables you to set up a “profile” that will bring up only those songs. For example, let’s
imagine that you have a folder in My Music that is labeled as “Freestyle.” Here’s how to
set up that profile:

. . . . m TTDCCOmeTs,
1. First, you would open the directory by clicking the Choose a director x|
yellow folder icon in the Filelist. Then you would look e e =
“ . » . [ Cumberland 05
under “Choose a directory” and click on the small 0 crtmied
square beside Freestyle. A checkmark would then ﬁiﬁ:‘éiﬂ:ﬂiiﬁi
R R Freestyle
appear in the box. If there are any other items ] L etbpzoon o}
. . [ Gatlinburg 2007 D3
checked that you would NOT want included in the B;ecff'é%gs
Freestyle profile, you would uncheck them. D e
[ Spring Fling 2004 CD1
[ Spring Fling 2004 CD2
. . . . . [ Springbore
2. Click on the arrow pointing right (see picture) to open P it
the PrOfIle dlalog bOX. [Jinclude Subdirectories
[ OK ” Cancel ] [ Reset J
3. Type in the name of the profile -
“« Choose a director:
under “Load, save or delete
stored profiles.” Type “Freestyle” o .
. [] Cumberland A06
in the rectangular box at the 0l it o
bottom. B Lo i s r s
Do CEne
4. Then, click “save” and you're %rf'b
done! D
[ Spring Fling 2004 CD1
, , B o
Any.tlme you want to I_oad a part_lcular s " - . S—
profile, open up the directory, click on Sl ,{
H. Freestyle
that profile, click “OK” and that profile == o N = WY i
will appear in your Filelist.

Warning: Do not put a check in the C: "box". Doing so will import your entire "C" drive
into ClogAmp!

Profiles can be kept to a manageable size when you separate your songs in
subfolders within your My Music folder based on their type, i.e. Hoedown, National
Dance List, Holiday music, Line dances, etc, or any other way you would like to sort
your music. In some instances you may have the same song in more than one folder. In
that case follow the instructions in Song/File Duplication (in later section) to insure all
copies have cue points.



PLAYLISTS

Playlists are comprised of songs that you pull from your folders to create a customized
“playlist.” For example, if | want a group of songs from the National Dance List, | would
create a playlist of those songs and then save it as “National Dance List.”

Playlists are easily created by: !
[ 29 fite(s), 01:03:03 hours ‘?‘
. . . . . . . . Title Length =
1. Highlighting a song in the Filelist and dragging it to At The Hop (L10) e ‘%}
. Get Back 02:29 (=)
the Playllst, Or by Little Red Riding Hood 03:37 d
Coalmine 03?0 ‘@
2. Highlighting a song, right clicking on it, and then e o | (B
. ghlig g g, 1g g ) Somebody Like You (103) [ON | (3
clicking on “Append to Playlist”. P ol ™
Would You Go With Me 03:48
. . . . Irish Medley 02:37
To provide you with a visual record of songs played in the e i
playlist (see image on right), they will be highlighted in BLUE | fretoereatend o
when played (Coalmine and Would You Go With Me have TS
been played; Somebody Like You is currently being played), [ o oo -

if you check “MARK SONGS WHEN THEY HAVE BEEN
PLAYED” under the tabs of Extra—>Options->Playlists.

You can play a song in the Playlist by highlighting it and
1. Pressing ENTER.

2. By double-clicking on the song.

3. By pressing the space bar. However, you will have to i i
press "p" (for PLAY) unless you check the following box: START PLAYING
WHEN A SONG IS SELECTED. Get there by going to Extra->Options=>
Playlists.

At the bottom of the Playlist (refer to image above right) is a box you can check which
says PLAY CONTINUOUSLY. This is very cool if you want to play songs continuously
and not have to manually start each song. This is useful if you need to take a quick trip
to the porta pottie © or if you have a warm-up period at a dance so that you don’t have
to stay near your laptop.

Right click on any song in the Playlist and you will find a smorgasbord of options that
let you remove songs, change the order of your songs, add silences between songs and
many other ways that can help you to fine tune the playlist.

Create a new Playlist by clicking on the "-" sign in the playlist menu bar and then click
"Remove All ltems". This clears the playlist and allows you to create a new one which
you can save under a new name.



You can view the Playlist in three ways:

1. Goto Extra>Configure Keys->Toggle Playlist, then type in the letter of the

key you want to use to bring up the Playlist. | chose

works best for you, or
2. Go to View and click on Playlist, or

3. Click on “P” in the Player at the bottom of your
player control screen.

Song/File Duplication

[ b

w” but choose whatever
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Each song you place in a My Music folder creates a separate file on your computer. If
you have the same song saved in several My Music folders then you may have several

different files for that song showing up in ClogAmp.

Since cue points are saved to the particular mp3 song file you are using when you set
them in ClogAmp, once you have set your cue points you may want to copy that song
file into any additional My Music folders that have the same song selection in them. By
doing so, all copies of that song file will have the same cue points.

If you rename your My Music folders/subfolders after you have used them to set your
profiles, OR move them to another location, OR delete any of them, you will need to

reset your profiles and playlists.




SETTING VARIOUS OPTIONS

Extra->Options>Audio
| set (based on Martin’s recommendation) .20 as the amount of time for fade-ins and
jumps. Feel free to experiment.

Extra>Options>Tempo and Pitch

Check these boxes if you want the program to remember your last settings. | love this
feature! Under "play event" in this dialogue box, determine the number of seconds that
you want to elapse when playing a song before you want the program to remember your
settings.

Setting Beats per minute (BPM)

If you are interested in knowing how many beats per minute a particular song has, go to
View->BPM Counter. | would suggest unchecking “Auto detect” because it's not
usually accurate. Press the space bar, as directed to the beat of the music, until it says
“finished!” in green lettering.

Timer
ClogAmp has a built-in Timer window so you won't miss the end time
of a workshop or patter call. To see the timer, go to View->Timer.

Once you have set the Timer for the allotted time, you can either leave it in view, if you
want to monitor it, or you can close it. If you close it, it will reappear and flash when your
specified time has expired!

You can bring the Timer into view by:
1. Going to the VIEW tab and then clicking on TIMER, or

2. Setting a key (I use "t") to bring it up. Do this by going to Extra->Configure
Keys->Toggle Timer, then type in the letter of the key you want to use to
bring up the Timer).



EQUALIZER

You can configure the equalizer as you desire and save it under “Save Custom.” You
can bring up your saved settings at any time by clicking “Presets” and then “Load
Custom.” This is particularly helpful for songs that need adjustment for either too much
bass or too much treble.

Fortunately, the next release of ClogAmp will “remember” the equalizer settings for each
song. You will be able to enable this feature by going to Extra->Options->Data and
check “Save and restore last equalizer setting per song.”

You can bring the Equalizer into view by:
1. Going to the VIEW tab and then clicking on EQUALIZER, or

2. Setting a key to bring it up. Go to Extra->»Configure Keys->Toggle Equalizer.
Then type in the letter of the key you want to use to bring up the Equalizer, or

n Williamson - Home Among The G
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CONFIGURING THE KEYBOARD

One of the very best components of ClogAmp is its ability to allow you to determine
which keys you want to control the various functions! This allows great flexibility for
each individual user to decide what system of commands works best.

To configure the command keys to your liking, “Trj‘-
go to Extra>Configure Keys. Many [ r— ey ;
command keys have already been allocated |

to numerous functions. If you see one that Passfienne Z

you would like to change, the good news is L i

that you can! The important thing to 4l | Temoo 100% Home

remember is this: if you want to use a key that il cessoton:

has already been allocated to another e

function, you must replace that key before
you can use it. For example, if you wanted to
use the letter “p

Reset to Default Keys I Lclose DialogJ

for something other than the

default setting of “play,” you would have to:

1.

Click on the function that you want to reset the key for. In this case, you would
click on “Play.”

. Delete the letter in the lower left hand corner of the dialogue box where it says

“key.”
Type in the letter you prefer instead.
Now go to the function where you want to use the letter “p” and highlight it.

Delete the designated letter that has been assigned to it.

Type in “p”.

Click on “Take Key” and you’re done.

I'll share my personal configurations that work well for me. | use ...

Key Function

for increasing tempo (1%). (When using you will actually hit the ">" key but
you will want to set the configuration to "." so you don't have to hit the Shift
key to trigger the ">" sign.)

,  for decreasing tempo (1%). (When using you will actually hit the "<" key
but you will want to set the configuration to "," so you don't have to hit the
Shift key to trigger the "<" sign.)

T  for toggling the Timer



Key Function

Q
w

A
F1

F2

for toggling the Equalizer

for toggling the Playlist

for pausing music (it is next to s, which stops the song)
for decreasing pitch (1%)

for increasing pitch (1%)

To toggle between the Filelist and the Playlist

for decreasing volume

for increasing volume. (You'll notice that the upper case letter is "+" but you
will want to set the configuration to "=" so you don't have to hit the Shift key
to trigger the "+" sign.)

to toggle the time remaining in the player. (This allows you to either see
how much time has elapsed as you play the song OR how much time
remains in the song. It's your choice.)



SETTING CUE POINTS

1. Select the song that you want to set cue points for.

2. Click the “Positions” tab in the upper left hand corner. btra View Help
Fileist | positions | Database
[ Directory: C:|Users |Roger | Music and others,

. Play the song that you want to set cue points for. Tite bt

3
4. Hit “pause” at the point where you want to insert a cue point.
5. Left click on the “Positions” tab.

6. Right click on any space in the “Positions” box and left click “add”.

7. Fillin “Name.” | usually put the name of the cue point here, o T
such as “Part A”. P —
“ » Position: : ;:‘:’2’::5000 [ Now
8. Under “Comment”, | usually put the names of the steps for .
that section here. For example: 2 Basics, Fancy Double. =T |
The Format of a position (or jump) is "MM:SS:LLL"
9. Left click “now”, located on the same line as “Position:” [Chen ] [Cose ]

10. Hit “save.”
11.You should see the cue point set as “#1.”

12.Restart the song and then hit the number “1” on your laptop. If it is the right spot
then you're set. If not, then adjust the time, save it, and try it again until you get it
right. It allows you to adjust the milliseconds so you can make it VERY accurate!
The time is set forth as:

MM (minutes):SS (seconds):MLS (milliseconds)
13.Do the same as above for all other cue points.

14.0nce finished, initiate any cue point by pressing the appropriate number on your
keyboard.

Important: File settings (cue points, tempo, etc) only save in the mp3 file format.

You can set the font size of the cue points by clicking on the UP and DOWN
directional arrows in the lower right corner of the screen. | make them large so they are
easy to see. Refer to the FILELIST section for a graphic of these arrows.

You can customize your “Positions” page so that you have your dance cues on
the same page as your cue points! After setting all your cue points, create a cue point
named “Sequence”, set the “Position” a second or two earlier than the length of the
song, and list the sequence of your dance in the “Comment” section. To create a visual
break between your cue points and your “Sequence”, create an unnamed cue point by
hitting the space bar for the “Name”, leave the “comments” section blank and set a
position that is between your last cue point and your “Sequence” cue point.



LOOPING

Looping is repeating a section of music as many times as needed to lengthen your song
and is particularly useful for songs that you want to play for a long time, like a hoedown.

Looping is very similar to setting cue points, except that you are setting two cue points:

the beginning (which is the start of the section you want

to repeat) and end (which is the end of the section you Edit .. R, =
want to repeat) of your loop. * @

1. Hit “pause” at the point where you want the end :” ) ::"‘*“"w“‘-‘“’e‘;“"”'e“
of your loop to be. (In this example, at the 39- e o> e
Second mark.) Jump to:  00:25:000 ‘_[\‘2!\'_‘

[ Test jump | l Swap ‘

2. Click on “Now” located on the same line as The Fomat ofaposion (o urg) s S5
“Position:” which will then indicate where you : '1 S e
want the end of the loop to be marked.

3. Make adjustments as necessary (see setting cue ) B ) B 0 5 e
points).

4. To set the beginning of your loop, play the music and hit “pause” at the point
you want your music to loop back to. (In this example, at the 25-second mark.)

5. Click on “Now” in the “jump to” tab.

6. Click on “Save.”

7. Click on “Test jump” to see if you need to fine tune your loop.

8. At the bottom of the dialogue box, you can indicate how many times you want the
loop to play before the song plays through to the end.

9. The example shown above will loop back to the 25-second mark of the song and

play through to the 39-second mark.

You have three options once you have created a loop:

You can put a “checkmark” in the box labeled “jump” at the bottom of your
dialogue box, with “number of times” set to “0,” the song will loop indefinitely (see
above graphic).

You can put a “checkmark” in the box labeled “jump” and denote the number of
times you want it to loop before playing all the way through.

You can leave the box “jump” unchecked and the song will play normally.

You can also set the font size of this screen by clicking on the UP and DOWN
directional arrows in the lower right corner of the screen. | make them large so they are
easy to see. Refer to the FILELIST section for a graphic of these arrows.



BURNING CD’S

You can easily burn a music selection in MP3 format or WAV format (which is typically

used for CD players). Go to Extra->Save to file  [F cogimp - Woud Vo co Witk Ve ek Tormerres

and burn your selection to the CD or save the JEE ewn bic

file on your desktop or another folder. The really gptfg,(ey LFDMe,s,mgﬁ/esmm
cool thing is that it will burn the music selection S »[ Savetowavfie..
at the tempo you last played it at (assuming that _ L mem Kﬁsm‘ L
you have check marked the “tempo and pitch” (Let Ve Ee Your) Teddy Bear Evis Presiey

boxes under Extra>Options>Tempo and Pitch).

Please note that while tempo, pitch and equalizer settings will transfer when you burn a
song to a cd, any loops or jumps you have created will not.



MISCELLANEOUS TIPS

When running music through an amplifier, experience has shown that what works best
is keeping your laptop volume on a LOW level, while using the amplifier to increase
the volume to desired levels. Otherwise, the music will likely become distorted if your
laptop volume is too high.

The music can be started from any position within the song by hitting the “F” key to
move forward. Hitting the “B” key will move you 5 seconds backwards in the song.

If you are unsure of what a button does, try to hover over it with the mouse to get a tip.

ClogAmp never crashes ©. If it does anyway, remember that deleting 'clogamp.ini'
and/or 'clogamp.db’ will reset all settings and usually fix the problem. ClogAmp is
designed to have a very small footprint on any system and in fact does not touch any
files outside of its installation directory. On installation, it is about 1MB in size but it uses
a database that grows depending on the amount of files you are using and how often it's
used.

ClogAmp is started by running the main executable — ClogAmp.exe. It will create the
files 'clogamp.ini' and 'clogamp.db’ in the directory where the executable is located.
Renaming those two files can solve potential problems (remember that, in case
ClogAmp happens to not work when you really need it on stage), as it will reset all
settings and clear the database (renaming the files rather than deleting them allows you
to go back to them and more importantly to send them to the developers to see what
went wrong). When moving a ClogAmp installation, make sure you move the whole
content of the installation folder, not just the executable.

Use Win+C to bring ClogAmp to the front — no matter where it was before.

All settings and positions you save for a song file are saved directly in the file. If you
transfer the song file to another computer on which ClogAmp is installed, the saved
settings and positions travel with it.

ClogAmp can read both MP3 and WAV files. It cannot play songs directly from a
regular CD (CDA file). The files must be ripped to the computer first.

In both the Filelist and the Playlist, you can highlight a file |[&ie = e |

. . ; . || Fiename:  Vusic \Clogging\Cumberland A06\Coalmine - Sara Evans.mp3 5
name and click on the edit button ® to edit the . \
information for that file. You can change the artist, title, S e

. . Album: Cumberland A06
album, difficulty level, BPM, genre, year and add a il ...

comment to the file. \

Genre: Country

Under the Database tab, you can find information on the Lo 03
songs that you have played. ClogAmp keeps track of the DA e e -

Bitrate: 192 kBit/s

songs played, when they were played, and how many e ————
times you played each song.




Additional program information is available at http://www.clogamp.com.

If you have any questions, additions or corrections, please contact either Jayne
Treadwell (Learn2Clog@hotmail.com) or Roger Henthorn (cscloggers@fuse.net).



http://www.clogamp.com/
mailto:eastcountry@nc.rr.com
mailto:cscloggers@fuse.net
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